Archive for category jQuery

Error Install-Package : Conflict occurred. ‘jQuery 1.5.1’ referenced but requested ‘jQuery 1.6.4’. ‘jQuery.vsdoc 1.5.1, jQuery.Validation 1.8. 0, jQuery.UI.Combined 1.8.11’ depend on ‘jQuery 1.5.1’

I was trying to install SignalR using NuGet package manager :-

install-package signalr

and get the following error :-

Install-Package : Conflict occurred. ‘jQuery 1.5.1’ referenced but requested ‘jQuery 1.6.4’. ‘jQuery.vsdoc 1.5.1, jQuery.Validation 1.8.
0, jQuery.UI.Combined 1.8.11′ depend on ‘jQuery 1.5.1’.
At line:1 char:16
+ install-package <<<<  signalr
    + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

So, It looked like jQuery 1.5.1 was referenced in my app. So, I looked that up and It was found in the package.config.

Capture1

All I had to do is to remove all the jQuery references (highlighed above) and retry installing SignalR again and It got installed successfully this time.

PM> install-package signalr
‘SignalR 0.3.5’ already installed.
Successfully added ‘Microsoft.Web.Infrastructure 1.0.0.0’ to UsingSignalRWithMVC.
Successfully added ‘SignalR.Server 0.3.5’ to UsingSignalRWithMVC.
Successfully added ‘jQuery 1.6.4’ to UsingSignalRWithMVC.
Successfully added ‘SignalR.Js 0.3.5’ to UsingSignalRWithMVC.
Successfully added ‘SignalR 0.3.5’ to UsingSignalRWithMVC.

, ,

3 Comments

Random Thoughts

The World as I see it

Simple Programmer

Making The Complex Simple

Ionic Solutions

Random thoughts on software construction, design patterns and optimization.

Long (Way) Off

A tragic's view from the cricket hinterlands